Anybody experienced with the Lowrence Elite 5 TI sonar unit

Talk about the gear that makes your fishing day.
Post Reply
User avatar
The Quadfather
Rear Admiral One Star
Posts: 3804
Joined: Tue May 08, 2007 2:27 pm
Location: Carkeek Park, North Seattle
Contact:

Anybody experienced with the Lowrence Elite 5 TI sonar unit

Post by The Quadfather » Sat Jun 30, 2018 9:43 pm

I just sold my boat after 11 years of good times boating. I am moving into a Hobie Pro Angler 14, mirage drive kayak.
These kayaks come with some pre-setup stuff that seems to lean toward installing Lowrence fish finders.
I currently own 3 Humminbirds, and I'm very dialed into that product. I have not used a Lowrence before. I realize that I can put whatever I want on this Yak, but I am keen on the fact that Lowrence uses a screwed in system for the cables on the back of the head unit. This stops any wave splash from getting into the electronics. My Humminbirds are just the push in cables.

Anyway, do any of your run the Lowrence elite TI units? Are you happy with their performance?

I had a 'Lawrence' with the (a) a few years back and it was the worst thing I've ever bought. I always thought it was weird that two sonar companies would spell their name so similar...
Last edited by The Quadfather on Mon Jul 02, 2018 11:05 am, edited 1 time in total.

User avatar
kodacachers
Lieutenant
Posts: 256
Joined: Tue Jul 08, 2008 2:18 pm
Location: Bellevue

Re: Anybody experienced with the Lawrence Elite 5 TI sonar unit

Post by kodacachers » Mon Jul 02, 2018 10:45 am

I used to have (until yesterday) a Lowrance Elite 7 HDI. I was generally happy with it. It had two issues: Losing depth at speed (probably not an issue you'll have) and in deeper saltwater (over 150 ft) I never got it dialed in to filter out all the noise. I think the first problem was user error (transducer placement) and the second may have been as well. I really liked it in freshwater and shallower salt. Going with an HDS Carbon on the new boat. Have fun with your new fishing adventure!

User avatar
The Quadfather
Rear Admiral One Star
Posts: 3804
Joined: Tue May 08, 2007 2:27 pm
Location: Carkeek Park, North Seattle
Contact:

Re: Anybody experienced with the Lowrence Elite 5 TI sonar unit

Post by The Quadfather » Mon Jul 02, 2018 11:07 am

Thanks Kodcatchers, I think I’ll be happy with this. There is sort of a special place for the transducer on the Yak.

User avatar
Racer
Warrant Officer
Posts: 158
Joined: Tue Mar 17, 2009 1:37 pm
Location: algona, wa

Re: Anybody experienced with the Lowrence Elite 5 TI sonar unit

Post by Racer » Thu Jul 05, 2018 11:56 am

I've had an Elite 5 for about 6 yrs now. The only time I had problems was when I cracked the transponder. Once it's dialed in it shows me a pretty good picture. I have used it on fresh and saltwater.

User avatar
The Quadfather
Rear Admiral One Star
Posts: 3804
Joined: Tue May 08, 2007 2:27 pm
Location: Carkeek Park, North Seattle
Contact:

Re: Anybody experienced with the Lowrence Elite 5 TI sonar unit

Post by The Quadfather » Thu Jul 05, 2018 12:11 pm

Good to know.
I just picked up the Kayak yesterday, with the Elite 5 of course. Prob will take me a little while to experiment with it.
What I really value is that the connections on Lowarance are actually sealed/twist, considering a kayak takes a lot of wave hits.

User avatar
Racer
Warrant Officer
Posts: 158
Joined: Tue Mar 17, 2009 1:37 pm
Location: algona, wa

Re: Anybody experienced with the Lowrence Elite 5 TI sonar unit

Post by Racer » Thu Jul 05, 2018 12:33 pm

They help but good practice to still put some dielectric gel in the connectors. I have had condensation get into them when installed for a length of time. That will keep the connections good.

Post Reply